29th June 2021

Synapse Federation message latency.

We are aware that multiple servers across the federation are experiencing high message latency in federated traffic, this includes the matrix.org instance.

We are actively working to resolve the issue and expect performance to improve throughout the day.

UPDATE: 14:00 UTC 2021-06-29 We are seeing a large scale attempt to bulk-register bot accounts across the public Matrix network (including captcha bypass) in order to perform spam flood attacks. If you're running a public homeserver please disable open registration, or require email for signups.

https://twitter.com/matrixdotorg/status/1409873992454967304

UPDATE: 22:23 UTC 2021-06-29

Admins: If your homeserver is experiencing degraded federation performance following the recent flood of spam across the Matrix network, please consider updating to Synapse v1.37.1rc1. https://github.com/matrix-org/synapse/releases/tag/v1.37.1rc1

A full release will follow tomorrow

https://twitter.com/matrixdotorg/status/1409987186628378634

UPDATE 20:00 UTC 2021-06-30

We consider this incident to be resolved. More details at https://matrix.org/blog/2021/06/30/security-update-synapse-1-37-1-released