Degraded performance across client endpoints

Incident Report for Matrix

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 11:35 UTC

Monitoring

The degraded performance was linked to a harmless error which nevertheless was being reported millions of times per hour, affecting CPU.
We've fixed the error and service appears to be stabilising.
Posted Oct 13, 2025 - 09:27 UTC

Investigating

We are currently investigating this issue.
Posted Oct 13, 2025 - 08:57 UTC
This incident affected: Matrix.org (Synapse).