Reports of requests to libera.chat failing

Incident Report for Matrix

Resolved

The homeserver seems to be handling requests normally now.
Posted Nov 30, 2022 - 12:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2022 - 12:47 UTC

Update

...
Posted Nov 29, 2022 - 12:47 UTC

Investigating

We have received reports that some requests to the libera.chat homeserver are failing (HTTP 502 Bad Gateway), including room alias lookups. We suspect a problem with libera.chat's internal rate limiting logic and are investigating.

See https://github.com/matrix-org/synapse/issues/14462 and https://github.com/matrix-org/synapse/issues/14480 for more details.
Posted Nov 28, 2022 - 11:31 UTC